`
897371388
  • 浏览: 523473 次
文章分类
社区版块
存档分类
最新评论

HDU 1266 Reverse Number (water ver.)

 
阅读更多

Reverse Number

http://acm.hdu.edu.cn/showproblem.php?pid=1266

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.

Output
For each test case, you should output its reverse number, one case per line.

Sample Input
3 12 -12 1200

Sample Output
21 -21 2100

水。


完整代码:

/*0ms,208KB*/

#include<cstdio>
#include<cstring>

char s[15];

void solve(char* s)
{
	int i, j, len = strlen(s);
	for (i = len - 1; i > 0; --i)
		if (s[i] != '0') break;
	for (j = i; j >= 0; --j) putchar(s[j]);
	puts(s + i + 1);
}

int main()
{
	int t;
	scanf("%d\n", &t);
	while (t--)
	{
		gets(s);
		if (s[0] == '-')
		{
			putchar('-');
			solve(s + 1);
		}
		else solve(s);
	}
	return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics